Zend FR

Consultez la FAQ sur le ZF avant de poster une question

Vous n'êtes pas identifié.

#1 27-09-2016 16:09:18

Brianstorm
Nouveau membre
Date d'inscription: 27-09-2016
Messages: 4

Installation ZendGUardLoader 7.0.0 Ubuntu Server 14.04 PHP 5.6.26

Hello !

Je rencontre des difficultés à installer ZendGuardLoader 7.0.0 sur un serveur Ubuntu 14.04. Ma version PHP est 5.6.26, j'ai beau suivre les instructions du site de Zend ou alors ici :
http://idroot.net/tutorials/how-to-inst … ntu-14-04/

Mais rien ne semble fonctionner, php -m ne m'indique pas que ZendGuardLoader est chargé.

Le contenu de mon dossier /usr/lib/php5/20131226/ :

Code:

root@test:/usr/lib/php5/20131226# ll
total 2164
drwxr-xr-x 2 root root    4096 Sep 21 01:06 ./
drwxr-xr-x 4 root root    4096 Sep 22 07:41 ../
-rw-r--r-- 1 root root  110008 Jun 24 06:05 gd.so
-rw-r--r-- 1 root root   72584 Feb  5  2016 json.so
-rw-r--r-- 1 root root  151240 Jun 24 06:05 mysqli.so
-rw-r--r-- 1 root root   56344 Jun 24 06:05 mysql.so
-rw-r--r-- 1 root root  155704 Jun 24 06:05 opcache.so
-rw-r--r-- 1 root root   31944 Jun 24 06:05 pdo_mysql.so
-rw-r--r-- 1 root root  114056 Jun 24 06:05 pdo.so
-rw-r--r-- 1 root root   31512 Jun 24 06:05 readline.so
-rw-r--r-- 1 root root 1471541 Mar 26  2015 ZendGuardLoader.so

Le contenu de mon fichier php.ini (pour la partie Zend) :

Code:

[Zend]
zend_extension=/usr/lib/php5/20131226/ZendGuardLoader.so
zend_loader.enable=1

J'ai bien relancé le serveur Apache2 mais celà ne change rien.

Savez-vous quelle étape j'ai raté ??
Merci de votre aide

Hors ligne

 

#2 27-09-2016 16:14:13

JGreco
Modérateur
Date d'inscription: 22-12-2012
Messages: 432

Re: Installation ZendGUardLoader 7.0.0 Ubuntu Server 14.04 PHP 5.6.26

php - m est une commande CLI, or le PHP.ini de ton CLI n'est pas le même que celui d'apache. Donc vérifies en premier lieu si ton PHPinfo via browser t'affiche bien ZendGuardLoader.

De là tu sauras si ton php.ini pour CLI doit être modifié ou pas, il est toujours possible que tu souhaite un PHP.ini différent.


ZF2 et doctrine addict
profil stack overflow : http://stackoverflow.com/users/3333246/ … ab=profile

Hors ligne

 

#3 27-09-2016 17:04:20

Brianstorm
Nouveau membre
Date d'inscription: 27-09-2016
Messages: 4

Re: Installation ZendGUardLoader 7.0.0 Ubuntu Server 14.04 PHP 5.6.26

Via bowser ZendGuardLoader n'est pas affiché.

Apache2 ne semble pas bien aimer l'ajout de la configuration Zend au php.ini :

[Tue Sep 27 11:02:28.418694 2016] [core:notice] [pid 20518] AH00051: child pid 20549 exit signal Segmentation fault (11), possible coredump in /etc/apache2

Hors ligne

 

#4 27-09-2016 22:15:27

JGreco
Modérateur
Date d'inscription: 22-12-2012
Messages: 432

Re: Installation ZendGUardLoader 7.0.0 Ubuntu Server 14.04 PHP 5.6.26

Du coup tu as une erreur de syntaxe sur ton PHP ini, je pense que le chemin de chargement de ton extension devrait être entre quotes.

Code:

zend_extension="/usr/lib/php5/20131226/ZendGuardLoader.so"

ZF2 et doctrine addict
profil stack overflow : http://stackoverflow.com/users/3333246/ … ab=profile

Hors ligne

 

#5 28-09-2016 04:24:13

Brianstorm
Nouveau membre
Date d'inscription: 27-09-2016
Messages: 4

Re: Installation ZendGUardLoader 7.0.0 Ubuntu Server 14.04 PHP 5.6.26

cela ne fonctionne pas mieux entre quotes.

D'autres idées ?

Hors ligne

 

#6 28-09-2016 06:34:07

Brianstorm
Nouveau membre
Date d'inscription: 27-09-2016
Messages: 4

Re: Installation ZendGUardLoader 7.0.0 Ubuntu Server 14.04 PHP 5.6.26

C'est bon j'ai résolu le problème enfin !!! il fallait également copier l'extension opcache.so contenue dans le package !

Hors ligne

 

Pied de page des forums

Propulsé par PunBB
© Copyright 2002–2005 Rickard Andersson
Traduction par punbb.fr

Graphisme réalisé par l'agence Rodolphe Eveilleau
Développement par Kitpages