Zend FR

Consultez la FAQ sur le ZF avant de poster une question

Vous n'êtes pas identifié.

#1 10-03-2012 09:58:03

HUGOBOSS00
Membre
Date d'inscription: 10-03-2012
Messages: 11

[Résolu]Probléme avec Zend_tool

Bonjour,
Je suis débutant dans le développement sous Zend Framework.Je commence à utiliser Zend Studio 8 et l'outil zend tool.J'ai bien configuré mon serveur et tous, et les commandes s’exécute normalement.
Le soucis est que lorsque je crée par exemple un model avec zf create model nom_du_model, je le supprime, et puis je lance la même commande avec le même nom du modèle, ça marche pas ! La commande est exécutée( selon la console) mais aucun fichier n'est crée.J'ai fais le clean de tous les projets, un nouveau build, mais ça marche toujours pas.Il faudrait que je change le nom du modèle pour que ça marche!
Des idées??

Dernière modification par HUGOBOSS00 (18-04-2012 09:32:37)

Hors ligne

 

#2 17-04-2012 14:39:48

fozzy38
Nouveau membre
Date d'inscription: 26-02-2011
Messages: 8

Re: [Résolu]Probléme avec Zend_tool

Bonjour,

la commande ZF met à jour le fichier .zfproject.xml. Est-ce que avant de relancer la commande vous avez fait du ménage dans ce fichier ?

Hors ligne

 

#3 17-04-2012 14:51:14

HUGOBOSS00
Membre
Date d'inscription: 10-03-2012
Messages: 11

Re: [Résolu]Probléme avec Zend_tool

qu'est ce que vous voulez dire par ménage?

Hors ligne

 

#4 17-04-2012 14:56:46

fozzy38
Nouveau membre
Date d'inscription: 26-02-2011
Messages: 8

Re: [Résolu]Probléme avec Zend_tool

et bien chaque appel à la commande zf va créer/modifier des lignes dans ce fichier.

Supprimer une action ou un contrôleur, veut dire à la main :
- supprimer tous les fichiers et vues concernés
- supprimer toutes les occurrences de ce que l'on veut supprimer dans le fichier XML

Attention, faire une copie du fichier avant toute modif, et bien vérifier que la structure XML soit toujours bonne. Ce fichier sert à tout le projet. S'il est corrompu, la commande ZF ne fonctionnera plus correctement.

Hors ligne

 

#5 17-04-2012 15:08:06

HUGOBOSS00
Membre
Date d'inscription: 10-03-2012
Messages: 11

Re: [Résolu]Probléme avec Zend_tool

Merci, mystère résolu smile

Hors ligne

 

#6 17-04-2012 17:31:04

fozzy38
Nouveau membre
Date d'inscription: 26-02-2011
Messages: 8

Re: [Résolu]Probléme avec Zend_tool

si vous pouvez modifier le titre du post pour mettre [Résolu]. Merci wink

Hors ligne

 

#7 17-04-2012 17:34:03

HUGOBOSS00
Membre
Date d'inscription: 10-03-2012
Messages: 11

Re: [Résolu]Probléme avec Zend_tool

je voulais bien le faire, j'arrive pas à mettre la main sur le lien pour le faire sad

Hors ligne

 

#8 18-04-2012 09:25:38

Orkin
Administrateur
Lieu: Paris
Date d'inscription: 09-12-2011
Messages: 1260

Re: [Résolu]Probléme avec Zend_tool

Il suffit d'éditer ton premier message et de changer le titre smile

Hors ligne

 

#9 18-04-2012 09:32:54

HUGOBOSS00
Membre
Date d'inscription: 10-03-2012
Messages: 11

Re: [Résolu]Probléme avec Zend_tool

Done:)

Hors ligne

 

Pied de page des forums

Propulsé par PunBB
© Copyright 2002–2005 Rickard Andersson
Traduction par punbb.fr

Graphisme réalisé par l'agence Rodolphe Eveilleau
Développement par Kitpages