Zend Framework

Consultez la FAQ sur le ZF avant de poster une question

Vous n'êtes pas identifié.

#1 13-02-2017 15:26:31

Yacine31
Nouveau membre
Date d'inscription: 19-01-2017
Messages: 5

Erreur authsso CAS

Bonjour à tous !

J'avance de + en + sur ZEND et je comprends de mieux en mieux ses rouages smile

J'ai enfin fini de débugger l'application que j'ai récupéré d'un autre développeur mais lorsque je passe de l'environnement de TEST vers l'environnement d'INTEGRATION, l'authentification SSO ne marche plus et lorsque j'essaye une authentification manuel voici le message d'erreur qui apparaît :

Code:

An error occurred

Application error

Exception information:

Message:

Stack trace:

#0 /var/www/html/library/PHPCAS/CAS/Client.php(1222): CAS_Client->validateCAS20('https://authsso...', '', NULL)
#1 /var/www/html/library/PHPCAS/CAS/Client.php(1081): CAS_Client->isAuthenticated()
#2 /var/www/html/library/PHPCAS/CAS.php(1100): CAS_Client->forceAuthentication()
#3 /var/www/html/library/Ruti/Controller/Api.php(47): phpCAS::forceAuthentication()
#4 /var/www/html/application/controllers/SecurityapiController.php(59): Ruti_Controller_Api->getSSOUser()
#5 /var/www/html/library/Zend/Controller/Action.php(516): SecurityapiController->loginAction()
#6 /var/www/html/library/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('loginAction')
#7 /var/www/html/library/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#8 /var/www/html/library/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#9 /var/www/html/library/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#10 /var/www/html/public/index.php(34): Zend_Application->run()
#11 {main}            
Request Parameters:

array (
  'controller' => 'Securityapi',
  'action' => 'login',
  'auth_mode' => 'sso',
)

Je ne comprends pas d'où peut provenir le problème alors qu'en environnement de TEST tout marche nickel et en environnement INTEGRATION je n'ai changé que les configs dans application.ini pour connecté aux nouvelles BDD.

Quelqu'un a-t-il une idée de l'origine du problème ?

Merci d'avance.

Hors ligne

 

#2 13-02-2017 16:44:01

Yacine31
Nouveau membre
Date d'inscription: 19-01-2017
Messages: 5

Re: Erreur authsso CAS

J'ai l'impression que c'est un soucis au niveau de l'authentification CAS

Hors ligne

 

Pied de page des forums

Propulsé par PunBB
© Copyright 2002–2005 Rickard Andersson
Traduction par punbb.fr

Graphisme réalisé par l'agence Rodolphe Eveilleau
Développement par Kitpages